Back to overview
Downtime

Backbone interruption between Iron Mountain and Nikhef

May 10 at 02:10pm CEST
Affected services
Website
Portal
Backbone

Resolved
May 10 at 02:25pm CEST

We have identified the cause and will work on an RFO.

Created
May 10 at 02:10pm CEST

We are experiencing downtime in Iron Mountain. We are still investigating.